Archive for February 19th, 2009

19
Feb
09

the damage continues!

well… here is a 2nd update since the car has been back.

its been a while, been busy with work and school.

well long story short when i picked the car up, it had to go back to api… i had a horrible burning oil smell, took it to the dealer, my block was discovered to have been leaking oil. great… well i drop the car off friday night, i am promised monday night for it to be done… wrong… its done tuesday night. eh water under the bridge… its fixed right… NO!

last week… my car is towed not once… but twice to the dealer for wiring issues!!!

i am now out $870 in repairs due to the wiring in my car being completely fucked and my fuses keep blowing, cars keeps not wanting to start and multiple tows in the same week.

i am going to pick up the car tomorrow from the dealer… hopefully it will work.

i also have to fork out the cash to have my front/side/rear bumpers painted when the new ones from ait racing come in. the ones on the car are horrible, they are basically trash. looks like there is going to be a delay on that.

thats gonna be more money too… all for stuff that IS NOT MY FAULT!

my savings account is completely bone dry empty now. my credit cards are climbing trying to get all of this fixed, and im losing my job within 3-4 weeks due to bankruptcy of the company. just a wonderful time!

i will start to update this blog regularly, i just need a digital camera. i will post pics of car as it progresses and is fixed and other meets and stuff and i will also post pics of my paint and fitment issues as soon as i get my hands on a camera.




February 2009
M T W T F S S
 1
2345678
9101112131415
16171819202122
232425262728